Excel PROCV

Uma das funções mais simples e populares para a tarefa de analisar dados é a PROCV (ou VLOOKUP, na versão em inglês).

Ela permite efetuar uma busca vertical (ou seja, ao longo de uma coluna) por um valor, retornando outros dados da linha correspondente.

Sintaxe: =PROCV(valor_procurado, matriz_tabela, núm_índice_coluna, [intervalo_pesquisa])

Para ilustrar o funcionamento da PROCV, montamos um exemplo simples, com a criação de uma planilha de cadastro para fazer uma simples busca com a função PROCV.

Crie a seguinte planilha com os valores na tabela.

Insira o seguinte comando na célula B4.

=procv(B3;A9:D18;2;FALSO)

Aparecera o seguinte erro na célula B4 (#N/D).

Esse erro é bem comum de acontecer, o seu motivo é pelo simples fato de não informarmos um valor correto ao código.

[callout1] Curso de Excel Avançado [button url=”https://c.eduzz.com/78226″ target=”” size=”small” style=”saffronblue” icon=”” popup=”” title=””] Aprender Agora – Clique Aqui…[/button]
[/callout1]

Insira o código de valor 3 na célula B3.

A função PROCV é executada trazendo o nome CLAUDIO DAMASCENO cujo código é 3.

Execute o mesmo comando da função PROCV para os campos de Telefone e E-mail selecionando os campos específicos do mesmo e os seus índices.

B5: =procv(B3;A9:D18;3;FALSO)

B6: =procv(B3;A9:D18;4;FALSO)


Agora veja o vídeo abaixo com a explicação detalhada do PROCV

O próximo vídeo ensina a tratar erros na hora de buscar dados

Sabia que é possível fazer um PROCV Duplo no Excel?

 

Função SOMASE

Use a função SOMASE para somar os valores em um intervalo que atendem aos critérios que você especificar. Sintaxe:
=SOMASE(intervalo, critérios, [intervalo_soma])

Em que:

  • Intervalo: é o intervalo de células utilizadas para realizar a comparação;
  • Critérios: critérios ou condições que definem quais células devemos somar. Este critério pode ser em forma de numero, expressão ou texto;
  • Intervalo_soma: é o intervalo a ser somado, quando este não for especificado, na função, será utilizado o item intervalo.

Crie a seguinte planilha no Excel.

Escreva o seguinte comando na célula G7, incrementando a função =SOMASE(B7:B24;F7;D7:D24) com seus respectivos intervalos e critérios

O resultado é a soma dos valores de comissão da vendedora ANA.

Agora é sua vez, treine com o restante dos vendedores

Excel Avançado – Indice e Corresp Melhor Que PROCV

Uma das coisas mais complexas que encontramos ao trabalhar com Excel é ter que lidar com uma pesquisa de dados de muitos critérios, por exemplo imagine nesse instante que você trabalha em uma loja de roupas.

Nessa loja você vende produtos diversos como camisetas, calças, saias, bolsas, shorts, regatas, blusas entre outras.

Cada uma dessas peças tem diversas marcas e também diversos tamanhos para se trabalhar e senão bastasse temos diversas cores.

Apenas para fins de exemplo imagine então que uma camisa da Lacoste tem diversos tamanhos como pp, p, m, g, gg, eg.

Além disso essa camisa pode ser vermelha, verde, branca, azul, preta, amarela, laranja, rosa, marrom, entre outras diversas cores.

Você tem todos esses dados na sua planilha e até ai não há nenhum problema.

Até que….

Você precisa buscar informações detalhadas do estoque de um determinado produto, você quer saber quantas peças de camisa Lacoste Rosa tamanho G você tem no seu estoque.

[button url=”https://mestresdoexcel.com.br/loja/combo-excel-3/” target=”” size=”large” style=”coolblue” icon=”” popup=”” title=””]Curso Completo de Excel aqui…[/button]

E agora o que fazer?

Como já era de se esperar o Excel provê uma solução fantástica para esse problema, e não será necessário usar PROCV, usaremos apenas as funções de pesquisa conhecidas como Índice e Corresp.

Como num passe de mágica você fará a busca ideal para seu produto com muitos critérios na planilha

Veja o exemplo na aula abaixo:

Faça o download da planilha:

Donwload Planilha da Aula Indice com Area